Webpage Connection Refused

Hi! I have install sequenceserver a couple of months ago and it worked fine, now I want to enter sequencer server and the webpages only say Connection Refused, my firewall is inactive and when I run the command sequenceserver it says

WARN Will listen on all interfaces ( Consider using (–host option).

How can I fix this? Every advice can help, thanks

I think I should specify that I have the sequenceserver on a server and that I enter with the http:ip_address:4567, but no error is showing, only the connection refused, I have try on 3 different web browsers and I don’t know what I can do to fix it. I have reinstalled it, install the latest version of ruby and nothing, please help

Hey Regina,

Do things work if you launch SequenceServer with the -D switch, i.e.,

sequenceserver -D

– Priyam

When I launch sequenceserver -D it still doesn’t work, the output of -D is:

genomica@tesla:~$ sequenceserver -D

[2015-09-28 18:40:57] DEBUG Reading configuration file: /home/genomica/.sequenceserver.conf.

[2015-09-28 18:40:57] DEBUG Will use NCBI BLAST+ at: $PATH

[2015-09-28 18:40:57] DEBUG Will use BLAST+ databases at: /home/genomica/Database

[2015-09-28 18:40:57] DEBUG Found nucleotide database ‘PGSC_DM_v3.4_cds.fasta’ at ‘/home/genomica/Database/PGSC_DM_v3.4_cds.fasta’

[2015-09-28 18:40:57] DEBUG Found protein database ‘PGSC_DM_v3.4_pep.fasta’ at ‘/home/genomica/Database/PGSC_DM_v3.4_pep.fasta’

[2015-09-28 18:40:57] DEBUG Found nucleotide database ‘PGSC_DM_v4.03_pseudomolecules.fasta’ at ‘/home/genomica/Database/PGSC_DM_v4.03_pseudomolecules.fasta’

[2015-09-28 18:40:57] DEBUG Will use 1 threads to run BLAST.

[2015-09-28 18:40:57] WARN Will listen on all interfaces ( Consider using (–host option).

[2015-09-28 18:40:57] INFO WEBrick 1.3.1

[2015-09-28 18:40:57] INFO ruby 1.9.3 (2013-11-22) [x86_64-linux]

[2015-09-28 18:40:57] INFO WEBrick::HTTPServer#start: pid=42534 port=4567

** SequenceServer is ready.

Go to http://localhost:4567 in your browser and start BLASTing!

Press CTRL+C to quit.

But the web browser only shows Failed to load resource: net::ERR_CONNECTION_REFUSED

How can I fix this?

Hey Regina,

Apologies, I don’t know what could be causing this problem and I’m not sure how much of it I can help debug over email. Does SequenceServer load at http://localhost:4567? Do you have any other servers running locally that load fine?

The warning emitted by SequenceServer simply means that if you don’t want others on your local network to access your SequenceServer installation (at http://your-ip:4567), start the server at instead of It seems that your setup is for shared usage, so you can ignore that warning.

– Priyam

Hi Priyam,

I appreciate your effort in trying to solve this problem, when I start the program, if I put on the browser of that server http://localhost:4567, it loads normally. The thing is that when I try to open it on another computer by typing http:my_ip_address:4567, it doesn’t load. At first I thought it was a problem of firewall, but the firewall is inactive, so I don’t have a clue of what it could be, any advice on this? Thanks in advance.

Hey Regina,

Does it work if you tell SequenceServer your ip:

sequenceserver --host

Which in your case would be I think: sequenceserver --host

When run this way I think you will have to use your IP to access SequenceServer locally as well.

– Priyam

Hey Priyam,

I have try it how you told me but still nothing shows up on the web browser. :frowning: