tilt/erb error? Results never displayed?

My users have been complaining that the SequenceServer BLAST search isn’t returning results - ever. Sure enough, I tried a quick test run, and monitored my system - the BLAST executables ran for the expected amount of time, and then they finished - and here I am 10 minutes later and still no results in the UI. The console only has this to say:

WARN: tilt autoloading ‘tilt/erb’ in a non thread-safe way; explicit require ‘tilt/erb’ suggested.

Any suggestions? I’m running SequenceServer 1.0.9, at http://culture-bioinformatics.org:4567

And a quick update - the system memory was totally eaten up. I restarted everything and a “simple” BLAST went through just fine. Not sure if the memory issue is related to the tilt/erb issue, but I’m suspecting that it was the memory more than anything that was causing BLAST to not return the results…

One more update - a “failed” BLAST (protein blast, if it matters) also wrote this to the console:

/var/lib/gems/2.3.0/gems/sequenceserver-1.0.9/lib/sequenceserver/blast/formatter.rb:44: warning: conflicting chdir during another chdir block

tilt/erb warning is innocent.

'conflicting chdir during another chdir block’ warning is probably the culprit. You don’t use Apache + Passenger setup, do you? It’s the built-in server started via upstart/systemd, right?