SequenceServer won't launch http://localhost:4567

Good morning,

I am running with this problem for a couple of days already and I seem unable to get over it. The problem is that after installing SequenceServer and all its dependencies (not problems arised) in Ubuntu 16.04 LTS, I run sequenceserver and the lines below appear in the terminal but, it does not launch the browser to localhost:4567 (I am using Firefox and I have apache2 installed with the localhost working properly)

Database dir not set.

SequenceServer needs to know where your FASTA files or BLAST+ databases are.
Please enter the path to the relevant directory (default: current directory).

Press Ctrl+C to quit.

I’ve tried setting the database dir and the rest of the configuration parameters in .sequenceserver.conf but nothing seems to be able to launch the localhost:4567. The thing is that SequenceServer seems to be working fine but it cannot access the port ¿? (moreover , if I point to the browser to http://localhost:4567 firefox is unable to connect to it even though when sequenceserver is supposed to be running)

And just to finish it seems the problem is not my computer either as I’ve tried to install SequenceServer in another machine (with Ubuntu 16 as well) and the same problem happened.

Do you know anything that could be causing this problem? I will appreciate any help cause it is getting very frustating



Just to add some more data …I’ve tried changing the port and nothing happened.

What happens after you enter path to the database directory? Please could you post the rest of the output here?