SequenceServer set up on a server without root access

Hi everyone,

I’m very interested in setting up sequenceServer on one of the server i’m using at work. But, I have no root access on that server which is shared with many other users. Each user has their own www/ directory. However, I see that sequenceServer has already been installed:


echo “$(ruby -e ‘puts Gem.path[0]’)/gems/sequenceserver-1.0.8”

How can I set up a web server of sequenceServer with my customised databases knowing it’s already installed and I have no root access?

Any help would be highly appreciated.


You should have a ‘sequenceserver’ command then. Run the command and it will guide you through the setup and run SequenceServer on port 4567. Then best to ask your IT folks to set you up with a VPN access so you can access your SequenceServer instance from home as well.



Thanks a lot for your answer. I forgot to mention that when i run the ‘sequenceserver’ command from this server, bash doesn’t recognize it, even though it’s installed as indicated previously in my message:

~ $ sequenceserver -bash: sequenceserver: command not found

I will speak with the admins of the server.

Use full path of the sequenceserver command on your system:


To avoid having to type the long path add the following to your ~/.bashrc:

export PATH="/usr/local/bioinfo/lib/ruby/gems/1.9.1/gems/sequenceserver-1.0.8/bin:$PATH"


Thanks. I have tried your command but it gives me this error:

-bash: /usr/local/bioinfo/lib/ruby/gems/1.9.1/gems/sequenceserver-1.0.8/bin/sequenceserver: No such file or directory

It seems like it may not have been installed properly since there’s no bin folder in ’sequenceserver-1.0.8' . I’m waiting for this answer. Cheers.

Could you give it one more shot:


And if it works, add this to .bashrc instead:

export PATH="/usr/local/bioinfo/lib/ruby/gems/1.9.1/bin/sequenceserver:$PATH"


It does not work unfortunately:

-bash: /usr/local/bioinfo/lib/ruby/gems/1.9.1/bin/sequenceserver: No such file or directory

I searched everywhere for the sequenceserver binary and I couldn't find it. I'm still waiting for their answer. Is there no other way to install sequenceserver without root access?



mkdir .gem
export GEM_PATH="$HOME/.gem"
export GEM_HOME="$HOME/.gem"

export PATH="$HOME/.gem/bin:$PATH"

gem install sequenceserver

This is from the top of my head. But my bet is, if anything I got only the PATH part wrong. If so, just look in ~/.gem for a bin directory and run sequenceserver from there.