sequenceserver not displaying databases

I have installed sequenceserver, the blast binaries, and the blast databases on my machine. I have also specified the paths to the binaries and databases in .sequenceserver.conf, but when I run sequenceserver and access the local web page, there are no databases displayed. I can type in a sequence and it detects, but I cannot blast the sequence because there are no databases shown. Below is the output when I run sequenceserver:

== Initializing SequenceServer…
I, [2013-11-08T17:50:26.505756 #7808] INFO – : Found blastn at /home/thomaschow/ncbi-blast-2.2.28+/bin/blastn
I, [2013-11-08T17:50:26.505984 #7808] INFO – : Found blastp at /home/thomaschow/ncbi-blast-2.2.28+/bin/blastp
I, [2013-11-08T17:50:26.506076 #7808] INFO – : Found blastx at /home/thomaschow/ncbi-blast-2.2.28+/bin/blastx
I, [2013-11-08T17:50:26.506157 #7808] INFO – : Found tblastn at /home/thomaschow/ncbi-blast-2.2.28+/bin/tblastn
I, [2013-11-08T17:50:26.506272 #7808] INFO – : Found tblastx at /home/thomaschow/ncbi-blast-2.2.28+/bin/tblastx
I, [2013-11-08T17:50:26.506368 #7808] INFO – : Found blastdbcmd at /home/thomaschow/ncbi-blast-2.2.28+/bin/blastdbcmd
I, [2013-11-08T17:50:26.506476 #7808] INFO – : Found makeblastdb at /home/thomaschow/ncbi-blast-2.2.28+/bin/makeblastdb
I, [2013-11-08T17:50:26.506569 #7808] INFO – : Found blast_formatter at /home/thomaschow/ncbi-blast-2.2.28+/bin/blast_formatter
I, [2013-11-08T17:50:26.509996 #7808] INFO – : Found sh: database: /home/thomaschow/ncbi-blast-2.2.28+/bin/blastdbcmd: not found at 1:

I, [2013-11-08T17:50:26.535248 #7808] INFO – : Using Thin web server.

== Launched SequenceServer at:
== Press CTRL + C to quit.

Any help is appreciated, thanks!

Hi Thomas,

Would you mind sharing your .sequenceserver.conf file please?


Path to the blast executables.

Hi Thomas,

I apologise I did not read your original error message as closely as I might. The problem appears to be this line:

I, [2013-11-08T17:50:26.509996 #7808] INFO – : Found sh: database: /home/thomaschow/ncbi-blast-2.
2.28+/bin/blastdbcmd: not found at 1:

It’s a bit strange, but I think that either means that there might be something wrong with your blastdbcmd program (part of ncbi blast). What happens if you run this command?

/home/thomaschow/ncbi-blast-2.2.28+/bin/blastdbcmd -recursive -list -list_outfmt “%f”


Hi Ben,

When running your suggested command I get “bash: /home/thomaschow/ncbi-blast-2.2.28+/bin/blastdbcmd: No such file or directory”.

OK, cool, we are getting closer to the problem I think. Actually there was a mistake in my last email. Try these

I get the following outputs:

thomaschow@radiant-Precision-T3610:~$ /home/thomaschow/ncbi-blast-2.2.28+/bin/blastdbcmd -h
bash: /home/thomaschow/ncbi-blast-2.2.28+/bin/blastdbcmd: No such file or directory
thomaschow@radiant-Precision-T3610:~$ /home/thomaschow/ncbi-blast-2.2.28+/bin/blastdbcmd -recursive -list /home/thomaschow/Documents/sequenceserver/tests/database/nucleotide -list_outfmt “%f”
bash: /home/thomaschow/ncbi-blast-2.2.28+/bin/blastdbcmd: No such file or directory
thomaschow@radiant-Precision-T3610:~$ ls /home/thomaschow/Documents/sequenceserver/tests/database/nucleotide
Sinvicta2-2-3.cdna.subset.fasta Sinvicta2-2-3.cdna.subset.fasta.nin
Sinvicta2-2-3.cdna.subset.fasta.nhr Sinvicta2-2-3.cdna.subset.fasta.nsq
thomaschow@radiant-Precision-T3610:~$ ls -lh /home/thomaschow/ncbi-blast-2.2.28+/bin/blastdbcmd
-rwxr-xr-x 1 thomaschow thomaschow 29M Nov 8 16:31 /home/thomaschow/ncbi-blast-2.2.28+/bin/blastdbcmd

Hmm, what about

/home/thomaschow/ncbi-blast-2.2.28+/bin/blastn -h