SequenceServer::DATABASE_DIR_NOT_SET

Hello,

I had sequenceserver running and online using apache2+passenger in our production server:

last week the sequenceserver app stop running from:

http://impam2.fmed.uba.ar/blast/

it was working all ok, but now it states it cannot find the database, It shows:

Something to be careful with when using SequenceServer with Apache is file permissions. Apache processes run as a different user (e.g., www-data, no-user) and this user may either not have the access to read your config file or your database dir. That’s probably what’s happening here.

Priyam

Hello Priyam,

Thanks for your reply,

I am still working around the issue, I tried the permissions but I did not have luck.

Here is my sequenceserver.service script for systemd:

root@impam2:/etc/systemd/system# more sequenceserver.service

`
[Unit]
Description = “running sequenceserver at startup”
Wants=network-online.target
After=network.target network-online.target
#After = network.target

[Service]
ExecStart = /var/lib/gems/2.3.0/gems/sequenceserver-1.0.11/bin/sequenceserver
User= glichtenstein

[Install]
WantedBy = multi-user.target

`

Here is the output when I check its status:

root@impam2:/etc/systemd/system# systemctl status sequenceserver
`
● sequenceserver.service - “running sequenceserver at startup”
Loaded: loaded (/etc/systemd/system/sequenceserver.service; disabled; vendor preset: enabled)
Active: active (running) since mié 2017-08-02 13:56:55 ART; 6min ago
Main PID: 30185 (ruby)
CGroup: /system.slice/sequenceserver.service
└─30185 sequenceserver

ago 02 13:56:55 impam2 systemd[1]: Started “running sequenceserver at startup”.
ago 02 13:56:55 impam2 sequenceserver[30185]: stty: ‘standard input’: Inappropriate ioctl for device
ago 02 13:56:55 impam2 sequenceserver[30185]: [2017-08-02 13:56:55] WARN Will listen on all interfaces (0.0.0.0). Consider using 127.0.
lines 1-10/10 (END)
`

Here are the permissions for the .sequenceserver.conf and .sequenceserver folder:

root@impam2:/home/glichtenstein# ls -hal .seq*
`
-rwxrwxrwx 1 root root 101 jul 14 19:20 .sequenceserver.ants.conf*
-rwxrwxrwx 1 glichtenstein soporte 99 ago 2 13:54 .sequenceserver.conf*

.sequenceserver:
total 36
drwxrwxrwx 2 root root 4096 jul 14 19:22 ./
drwx------ 64 glichtenstein soporte 32768 ago 2 13:56 …/
root@impam2:/home/glichtenstein#
`

Here is the contents of the .sequenceserver.conf file:

root@impam2:/home/glichtenstein# more .sequenceserver.conf
`

sequenceserver-port.png

sequenceserver-aliased.png

I have tried unsubscribing from this mailing list multiple times. I have not used sequence server in 6 years please, for the love of god someone remove from this list!

Hi Gabriel,

I am sorry for the slow response and for your troubles. Thanks for the info. It looks like SequenceServer is not able to read the config file. I think making your home directory readable and executable by others should resolve the issue:

chmod go+rx /home/glichtenstein

You may still get an error. But it should be “blast database error” or “no blast database found” instead of “database dir not set". In this case, you will want to similarly change permission for /share/apps/databases/sequenceserver (and its parent directories) so that the database files are readable by SequenceServer.

Priyam