one missing database in the interface

Hi Priyam,
I deployed sequenceserver 1.0.13 for ~80 databases that were previously indexed with makeblastdb.

One of my nucleotide database is not displaying in the interface, and I don’t know why : there is no error log, even with the -D option. I tried to index it with the 2.9.0 and the 2.2.31 makeblastdb releases.
Do you have an idea of what is going on? or an idea of how to investigate?

Hi Loraine,

In such cases, usually something would have gone wrong during the database formatting step. Did you use run makeblastdb yourself or let SequenceServer do it? If it is the latter, could it be that this particular database has a lot of Ns at the start of the file?

Other options are to check the output of blastdbcmd in command line to see if it is reporting the expected number of databases. Following is the exact command that SequenceServer runs:

blastdbcmd -recursive -list /path/to/database_dir/ -list_outfmt “%f %t %p %n %l %d”

Note that there is a tab character between the format specifiers (%f, %t and so on). If it does return the expected number of databases, there could be a bug in the parsing logic.

-D option should report each database that SequenceServer could find, which in turn should tally with what is displayed in the search form.


Thanks for your answer.
I run makeblastdb myself (I tried with version 2.9.1 and 2.2.31).
The blastdbcmd shows the database in command line, but not within sequenceserver with the -D argument. Strange!

[sequenceserver@sequenceserver ~]$ /usr/local/genome2/conda3/envs/blast-2.2.31/bin/blastdbcmd -recursive -list /my/path -list_outfmt “%f %t %p %n %l %d”
/my/path/my_db my_db Nucleotide 30 196804589 Apr 28, 2020 9:52 PM

[sequenceserver@sequenceserver ~]$ /usr/local/bin/sequenceserver -b /usr/local/genome2/conda3/envs/blast-2.2.31/bin -p 4580 -d /my/path -r /etc/sequenceserver/extension/sequenceserver.phaeoexplorer.rb -D
[2020-04-30 14:40:48] DEBUG Configuration file not found: /home/externe/application/sequenceserver/.sequenceserver.conf
[2020-04-30 14:40:48] DEBUG Will use NCBI BLAST+ at: /usr/local/genome2/conda3/envs/blast-2.2.31/bin
[2020-04-30 14:40:48] DEBUG Will use BLAST+ databases at: /db/local/sbr_non_biomaj/sbr_phaeoexplorer/current/blast/test
[2020-04-30 14:40:48] DEBUG Loading extension: /etc/sequenceserver/extension/sequenceserver.phaeoexplorer.rb
[2020-04-30 14:40:48] DEBUG Will use 1 threads to run BLAST.
[2020-04-30 14:40:48] WARN Will listen on all interfaces ( Consider using (–host option).
[2020-04-30 14:40:48] INFO WEBrick 1.3.1
[2020-04-30 14:40:48] INFO ruby 2.0.0 (2015-12-16) [x86_64-linux]
[2020-04-30 14:40:48] INFO WEBrick::HTTPServer#start: pid=12766 port=4580
** SequenceServer is ready.
Go to http://localhost:4580 in your browser and start BLASTing!
Press CTRL+C to quit.


Hi Loraine,

That’s indeed strange. Looks like you have been able to isolate the problematic database into its own directory. Any chance you could share a tarball of the folder containing both the fasta file and the BLAST database files (.nin, etc.) with me so I can look into it? Feel free to email me off the list.


more details on

I am glad you managed to resolve the issue. Thanks for further details and the pull-request!