"No BLAST method found error" and new formatted databases are not visible in sequence server

More people are reporting “No BLAST method found error” in my intranet now, Can you possibly help in resolving this issue.

If you need remote login to my machine, I can arrange that just let me know.

I have tried almost everything suggested by priyam but only the fixed given by him works for other apache+passenger hosted sequenceservers there is no solution.

Also, recently I have formatted new databases in one of the directories used by hosted sequenceservers but new databases are not visible .

I have restarted passenger and apache several times bu to no use. If manually launch sequenceserver by running its binary from command line then it is showing databases but for already hosted instances there are only old databases showing not new one.

I have infact deleted old databases in the directory and reformatted again using Sequenceserver -formatdatabases but still no clue how to deal with this situation.

Please suggest if 0.8.6 have some issues , should I revert back to 0.8.5

Maybe this is not totally related, but I get this same error if i press the “refresh” button on my browser after I have done a search. After I do the refresh, the sequence stays in the textarea, but the blast button is changed from BLASTN to BLAST (therefore no method is found)

I haven’t found many other instances of this error but perhaps this is related? I didn’t look at the previous discussion on this issue very closely so I hope i’m not out of place:)


Hey!!! everyone

It appears I have not properly setup the config file so the files were pointing to older db locations just for one instance which got me more confused…

And about “No BLAST method found error” , it was zeroed down to lacking of linking between js files used by SS. I upgraded my SS to 0.8.6 but Since I am not expert in ruby on Rails, So I did’t updated old js files with new ones and passenger continued using older files…

Issues resolved now!!!

As of Now Olympus has not Fallen!!!

Thanks to Priyam @@@@@@ for helping.