Nginx reverse proxy

I’ve setup a reverse proxy from nginx to the default port that sequence server runs on (localhost:4567). But it doesn’t seem to be working for me. I just added a simple proxy_pass line to my nginx config:

location /blast {
proxy_pass http://localhost:4567;

I have successfully reverse proxied to my other nodejs web services, so I don’t think it is a problem with the nginx routing config.

Sequenceserver was written with Sinatra? Is there something within the Sinatra framework that needs to be enabled for reverse proxies to work?


location /blast/ {
proxy_pass http://localhost:4567/;

That’s what I use for (with additional config, but that shouldn’t make any difference for routing).

Consider serving hosted js & css with Nginx and serving gzipped minified js & css (.min.gz is already distributed with SS).

– Priyam

Thanks Priyam. That did the trick. I guess the trailing slash is required for routing the static assets.