installation problem on Ubuntu server

Hi,

I’m trying to install sequenceserver on an Ubuntu server (Ubuntu 14.04.3 LTS). In the past I’ve successfully done this on another Ubuntu machine, and now I want to install it on a (headless) web server. That means (as far as I know) that I can’t try http://localhost:4567, but instead I go to the IP address of the web server, with the specified port of course.
The problem is that my browser can’t seem to make a connection to that url at all. I’ve tried various ports (using the -p option) and I tried specifying the IP address (using the -H option).
I’m running apache2 and tomcat on the same web server, with no problems at all. I can also ssh into it just fine.

Maybe I’m missing something simple. Any ideas on what I could try?

Thanks, Robin

Can you test it with curl from the same machine?

$ curl localhost:4567

… should return a sizeable HTML document.

If that doesn’t work either, try launching SequenceServer with -D option. But if curl works, then trying launching with -H option.

— Priyam

Hi Priyam,

Thanks for the quick reply. I tried that, and it works fine from the server. Next, I tried launching it with the -H option. Again, this works on the server itself. However, from another computer (either on the same network or on a completely different network) it just hangs. However, I can reach a webapollo instance on port 8080 (which uses tomcat). So, next I stopped tomcat and launched sequenceserver on port 8080 everything works!
So maybe port 4567 is blocked. I tried several other ports with no luck. I’m a bit of a noob when it comes to webserver/firewall settings. I will ask the IT department who set up the server, since it seems likely that they are blocking those ports (correct?).

Do I understand correctly that running sequenceserver on apache might circumvent this issue? I’ve tried setting that up in the past, using your instructions, but I couldn’t really figure it out. Maybe I’ll try again.

Thanks for your help, best regards, Robin

Yeah, running SequenceServer with Apache should do the trick.

Maybe try Terry Mun’s post on setting up SequenceServer with Apache+Passenger - https://medium.com/coding-design/setting-up-sequenceserver-edf9d992998c#.ezkkory9b

Since SequenceServer already works for you, you can skip straight to "Updating your Apache httpd configuration file” section.

(but it’s worth noting the pretty pic on top showing off the customisations he has made to his SequenceServer instance!).

— Priyam

Thanks, that post by Terry Mun was extremely helpful! I got it to work now, and it looks great. (Maybe a good idea to put this link on the sequenceserver site, so others can find it too?)

Thanks for making sequence server available, I look forward to using it.

Robin

Yep, that’s part of the plan - https://github.com/wurmlab/sequenceserver/issues/228

– Priyam

Hello Priyam,

After working on this a little more, I came across the following issue. The blast page looks different depending on whether or not I include a trailing slash in the url.
Blast page as expected:
http://fungalgenomics.science.uu.nl/blast/
Incorrectly formatted:
http://fungalgenomics.science.uu.nl/blast

Looking at the page source I believe it may be caused by an incorrect path to the CSS file.
This issue started after I used Apache/passenger. Any ideas on how to fix this?

Thanks, best regards,

Robin

This behaviour is correct: that’s how relative vs absolute URL work. SequenceServer uses relative paths. You need to configure Apache to rewrite foo.com/blast to foo.com/blast/ — see the group archives.

— Priyam