Installation of Sequence server on RHL 7.5


This is in reference to installing sequence server in Red hat linux 7.5 environment. We faced issues right from installing ruby into the environment and also faces some version issues.

Also, we tried using Docker for installation, but I believe that the link on docker installation is not working on your web page.

Please let us know how we can install on use sequence server on our RHL 7.5 environment.

Thank you


I am sorry I had missed this thread somehow. Ensuring sequenceserver can be accessed on variety of platforms is important.

I just tried installing sequenceserver in a CentOS based docker container, as it was easier to work with than RHEL. The following did the trick:

yum install ruby
yum install ruby-devel
yum groupinstall ‘Development Tools’

I am assuming this should hold for RHEL too as one derives from the other. Let met know if that helps.

Regarding docker, the command given on the website is:

docker run --rm -itp 4567:4567 -v /path-to-database-dir:/db wurmlab/sequenceserver:1.0.11

It should be:

docker run --rm -itp 4567:4567 -v /path-to-database-dir:/db wurmlab/sequenceserver

I will update the website as soon as I get the chance.