Does not return any results


I had a friend install sequence server for me (could not get it work myself) and it looks like everything works. All the blast databases are there, the page is up and you can submit a sequence and get a spinning wheel in response to submitting that sequence. However, it never returns any results, the page goes from url/sequenceserver/ to url/sequenceserver/#result but never actually returns anything. I get a spinning wheel on the query computer that lasts as long as the CPU usage on the server computer (less then 30 secs for most queries). I’m not sure how to proceed, does anyone have any suggestions? This is being run through apache2.


Hi Adrian,

Thank you for your interest in sequenceserver. If I had to guess at what your problem might be something to do with a timeout problem, perhaps on the client or the server side. Is there anything to report from the apache logs, which on linux are often at /var/log/apache ?

Can I ask, what browser and operating system are you using (same for client and server?)? Are you setting up sequenceserver for personal use or for other people to use as well?


Hello Ben,

Thanks for getting back to me. I will answer in reverse order and get the specific computer log files when I get to work. I am setting this up for my lab to use and a couple of outside collaborators, so it has to be non local. I am testing it on a client computer using chrome/Ubuntu but the other clients use everything else. The server is Ubuntu as well, maverick. Thank you very much.


I come with great (but a little confusing) news! I looked through the apache error logs and there were lots of entries which looked like successful calls to sequence server. There were entries for the query sequence and resulting hits from the databases. I went back to the client computer and used Firefox instead of chrome and it worked! So for whatever reason, on that computer chrome was not working but firefox did. Awesome! On an unrelated note, is there something in the works to make the summary of hits be justified instead of a single tab seperating the sequence name, the Bit score and the E value? It makes the table very difficult to read without all the data in 3 easy columns. Other then that it looks great and thank you.


An upgrade should resolve your issue.

-- Priyam

Is the upgrade available? Or is it a forthcoming upgrade?

My guess is that you are running SS version 0.8.2 or less. Version
0.8.5 is available.

-- Priyam

I am in fact running 0.8.2 (sequenceserver --version), however, when I try gem update sequenceserver, it says “Nothing to update”.

It's there:

Maybe it's some caching issue. Try `gem install` instead.

-- Priyam

I am very sorry to keep bothering you but I am having lots of difficulties. I have 0.8.5 installed (using gem list) but 0.8.2 does not show up in that list. The only version of SS that I can uninstall with gem uninstall is 0.8.5. If I type sequenceserver --version at the command line it comes up as 0.8.2. gem cleanup and gem uninstall don’t work since it doesn’t look like 0.8.2 is in any of those lists. I’ve installed and uninstalled 0.8.5 several times but it seems like 0.8.2 is always default. How do you recommend that I proceed, is there a way to completely remove all versions of sequenceserver so that I can try and start over? Thank you again.

Do you also have rvm installed?

-- Priyam

I do now. I followed this blog through rvm is a function and it works.

Well. The entire point of my question was to get you to remove RVM if
you have it :P. I give up. Maybe Ben can help. He always seems to
have some magical solution for RubyGems related issues that I don't

-- Priyam


I’ve come across this problem myself with rvm. My impression is that rvm does things is a very strange way and so it is hard to debug when these things happen.

Anyway, when you say you

followed this blog through rvm is a function and it works.

do you mean rvm works or seqserv works?

If you just mean rvm works, then I would suggest uninstalling all versions of ruby (including any modifications you made to .bashrc or .profile, and deleting ~/.rvm), and then install again from scratch (and logout of the computer and in again). What does “gem list sequenceserver” say? “which ruby”? “which gem”?

Good luck…


I once encountered that problem and switching to Firefox too solved it. Debugging and I noticed, in Chrome, the results are outputted. It’s just that, the HTML element created is not being brought forward to the current view. Looks like there is something wrong with the JavaScript codes. I will try to reproduce them on the coming days, I need to clear cache and restart web service to fully test SS again and I can’t do that for now since I have ongoing jobs running, for days now.

Removing the JS code that generates the index (on the right) resolves
the issue. Further insight into the problem would be great. Thanks,

-- Priyam