"Does not match input format type" despite previously working

I’ve been using Sequence Server for about a year now on behalf of a faculty member, and she sends me an updated file about once a month to create a database from. Up until this month, there wasn’t an issue with the file type–they’ve all been .txt files with the >name >sequence format. This month, she’s sent me a file with the same extension and format, but I am getting the error “Does not match input format type.”

I am using a VM with Ubuntu, using the terminal to run Docker and what should be the latest version of Sequence Server. The makeblastdb command still works with earlier .txt files, so the command and set-up itself doesn’t seem to have changed in a way that would cause this. I’ve also tried having the faculty member re-exporte the file to see if there was something wrong with that side of the process, but no change. The file is about twice as large as earlier versions (36mb vs 13mb), but that’s all I can really see as being majorly different (at least without knowing what else to look for).

I’ve been able to figure out other snags with Sequence Server on my own, but I’m a bit at a loss with this. I figure it wouldn’t hurt to see if anyone else has an idea of what might be causing an error in just this .txt file.

Thank you for your time and consideration!

Hi Diane,

Have you tried running your updated FASTA file through a validator to ensure that it is correct? That error message is telling you that the makeblastdb command has a conflict between the -input_type option flag (defaults to FASTA) and the actual format of the input file that it is receiving. My guess is that you have one or more records in your updated file that have a formatting issue that is causing this.


Hi Josh,

I haven’t! I’m not as familiar with that side of the process–thank you for the suggestion! It was very helpful, and I think I found some insight to what the issue is in the file.

Thanks again!