cannot deploy sequenceserver without being connected to the ubuntu VM


I installed sequence server but I cannot deploy on the web unless I am connected to my ubuntu VM.

I saw the info below from the documentation, but I created the file on my VM and I am thinking that somehow this new config file should be elsewhere or I should redirect sequenceserver to recognize the path to it. Could anyone provide some guidance?


Autostart on Ubuntu / Bio Linux
Create file /etc/init/sequenceserver.conf with the following content, changing author and setuid lines to your name and username:

description “Upstart config for SequenceServer”
author “”

start on filesystem
stop on shutdown


exec sequenceserver
Stop any SequenceServer instance you might be running and check the above works by running the following command:

sudo start sequenceserver

Which version of Ubuntu are you using? My understanding is that they have switched to systemd from upstart for startup scripts. So you probably want to refer to the section just above ‘Autostart on Ubuntu / BioLinux’ on the documentation page.


Thanks for your reply, I did not change to systemd, should I be doing that? What is the config file that I should be creating then, is it not the one on the ubuntu section?

My ubuntu is version 20.04.

Sorry, I am really a novice at this with little computer expertise.

Thanks! We have solved the problem. We did not know that we needed to modify the autostart with systemd.


I am glad :slight_smile:


Sorry, one more question…

If I wanted to customize the title of my sequenceserver page could I just go to the file: search.erb from the views folder and change this line:

SequenceServer: Custom BLAST Server


search.erb is probably the right file, but is “SequenceServer: Custom BLAST Server” what you see on the page that you want to change?


Dear Anurag,

What I see on the page is SequenceServer 1.0.14, but I could not find this in the file, and I thought the title line was what I needed to change.

Is there a different line that I should use?

One more question…

I wanted to change the names of some of my databases so they made more sense for users. I deleted some and included some with a new name on my databases folder, but it keeps showing the old name. Somehow it linked the old name to the new blast fomratted databases that I included.

When I go sequenceserver -l it shows me the name of the database (which is the old name I had), with the path to the new database I included:

nucleotide: CDS_nucl_new_e3_annotated-nr_060421.fasta /home/ubuntu/databases/CDS_nucl_new_e3_annotated-nr.fasta

Any clue why this is happening or how should I be changing the names so the databases show up with the new names on the web?


The simplest approach might be to:

Stop sequenceserver, delete all the non-fasta files in databases directory, start sequenceserver.


Thank you, I will try that!

Dear Anurag,

I tried to see if there were non-fasta files in the database folder I created but there are only the fasta files plus the index files generated when using makeblastdb, but I do not think you meant deleting those. It seems to me that sequence server automatically suggests a name, and for some reason it keeps linking that name and displaying it as associated with the database that was initially created, even if I stop the service, delete the specific database and re-add the same database but with a new name, the old name gets re-associated with the new database with a different name.

I see this on the webpage advance configuration:
SequenceServer can recursively scan a directory for FASTA files, identify whether the file contains nucleotide or amino acid sequences and prompt you to convert them into BLAST databases. It even suggests a suitable name for the BLAST database by cleaning up FASTA file name.

But I am not quite sure what it means. Is there a configuration file somewhere that has the automatically generated names per database?

Thanks for your help.

Dear Leanordo,

Those are precisely the ones I meant.

Once you run makeblastdb on the fasta files, the files that are generated are the databases. The name is encoded in those files. Renaming, or even removing fasta files has no effect once you have run makeblastdb.

Which is why - remove the files generated by makeblastdb and either run makeblastdb again yourself, or just rerun sequenceserver and it will run makeblastdb for you.

I hope this helps.


Thank you for your help.

I did what you recommended and it did ask me for a new name but ran into an error (see below). Is it the version of BLAST from sequenceserver the problem? Because when I format the databases externally with blast+/2.9.0 I have no issues.

ubuntu@blast-sequenceserver:~/databases$ sequenceserver -m

FASTA file: /home/ubuntu/databases/CDS_nucl_new_e3_annotated-nr.fasta
FASTA type: nucleotide
Proceed? [y/n] (Default: y): y
Enter a database title or will use ‘CDS nucl new e3 annotated-nr’: CDS_nucl_new_e3_annotated-nr
Enter taxid (optional):

Building a new DB, current time: 06/22/2021 15:58:58
New DB name: /home/ubuntu/databases/CDS_nucl_new_e3_annotated-nr.fasta
New DB title: CDS_nucl_new_e3_annotated-nr
Sequence type: Nucleotide
Keep MBits: T
Maximum file size: 1000000000B
Warning: (1306.7) [makeblastdb] NCBI C++ Exception:
T0 “/build/ncbi-blast±S1iyIZ/ncbi-blast±2.9.0/c++/src/objects/seq/…/seqloc/Seq_id.cpp”, line 2231: Error: ncbi::objects::CSeq_id::ParseIDs() - Unsupported ID type SPQ92915.1

No volumes were created because no sequences were found.

BLAST Database creation error: Could not construct seq-id from ‘ENA|SPQ92915|SPQ92915.1’

Your error message suggests that your sequenceserver installation is using blast+/2.9.0 as well. So it is probably the difference between how you ran makeblastdb externally and how sequenceserver runs it. The difference probably is the use of -parse_seqids option by sequenceserver to facilitate fasta download.

You have two options:

  1. Run makeblastdb as before. Note that you can use the -title option to set the desired database name. Here, fasta download from sequenceserver’s results page probably won’t work for you.

  2. Change sequence id in your fasta files so that it works with how sequenceserver runs makeblastdb:

See It is probably a bit old, but relevant.

I did a quick test and the following variations of ENA|SPQ92915|SPQ92915.1 id worked:


I do not know which one, if any, is appropriate in your context. I am curious though. Did you make the ENA|SPQ92915|SPQ92915.1 sequence id yourself, or was it already there when you downloaded the sequences from somewhere? Where did you get the sequences from?