Bug when trying to run sequenceserver

Hi, I installed sequenceserver just fine, but it can’t find my blast+ binaries or DB directory. So I went through the prompt and directed it to both, and it says it can’t find the FASTA files and wants to search for them. I say yes and it does and finds them, and I rename them. After the last rename I get this bug:


undefined method downcase!' for nil:NilClass /var/lib/gems/1.9.1/gems/sequenceserver-1.0.2/lib/sequenceserver/database.rb:25:in initialize’
/var/lib/gems/1.9.1/gems/sequenceserver-1.0.2/lib/sequenceserver/database.rb:109:in new' /var/lib/gems/1.9.1/gems/sequenceserver-1.0.2/lib/sequenceserver/database.rb:109:in block (2 levels) in scan_databases_dir’
/var/lib/gems/1.9.1/gems/sequenceserver-1.0.2/lib/sequenceserver/database.rb:106:in each_line' /var/lib/gems/1.9.1/gems/sequenceserver-1.0.2/lib/sequenceserver/database.rb:106:in block in scan_databases_dir’
/usr/lib/ruby/1.9.1/open3.rb:208:in popen_run' /usr/lib/ruby/1.9.1/open3.rb:90:in popen3’
/var/lib/gems/1.9.1/gems/sequenceserver-1.0.2/lib/sequenceserver/database.rb:102:in scan_databases_dir' /var/lib/gems/1.9.1/gems/sequenceserver-1.0.2/lib/sequenceserver.rb:130:in init_database’
/var/lib/gems/1.9.1/gems/sequenceserver-1.0.2/lib/sequenceserver.rb:40:in init' /var/lib/gems/1.9.1/gems/sequenceserver-1.0.2/bin/sequenceserver:131:in block (2 levels) in <top (required)>’
/var/lib/gems/1.9.1/gems/slop-3.6.0/lib/slop.rb:260:in call' /var/lib/gems/1.9.1/gems/slop-3.6.0/lib/slop.rb:260:in parse!’
/var/lib/gems/1.9.1/gems/slop-3.6.0/lib/slop.rb:65:in parse!' /var/lib/gems/1.9.1/gems/sequenceserver-1.0.2/bin/sequenceserver:12:in <top (required)>’
/usr/local/bin/sequenceserver:23:in load' /usr/local/bin/sequenceserver:23:in


Anyone have any ideas? Thanks!

I actually just tried rerunning this after emptying the db files it created from my db directory. It worked but I am unsure why when I tried this exact thing before. Any ideas what this error is and why it occurred in the first place?


This error has been brought up several times actually. The most common reason this happens is because the database files are corrupt. But I don’t understand why would SequenceServer raise this error right after creating them itself. It’s getting weirder by the day. I will hopefully find the time to thoroughly investigate this soon.

– Priyam

Okay thank you. It worked as I said, then I tried it again and it did not…

Hopefully it is revolved as soon as possible

This may be helpful. I used the same set of FASTA files to make my database in both instances. First instance I renamed the files to how I wanted them to appear on the server. Did not work, same error. Second time I renamed the FASTA files BEFORE running SequenceServer and just used the default names (which is what I wanted since I set up the names prior to show what I wanted on the server) and it worked perfectly.

Thanks - this suggests there is an error/issue with escaping the filenames.

Can you clarify what type of characters you put in? (e.g. were there spaces, apostrophes, $ signs or other non-normal letters?)


Something went wonky… ?


Something went wonky

Looks like you have encountered a bug in SequenceServer. Please could you

report this incident to our Google Group -



undefined method `downcase!’ for nil:NilClass

/Library/Ruby/Gems/2.0.0/gems/sequenceserver-1.0.2/lib/sequenceserver/database.rb:25:in `initialize’

/Library/Ruby/Gems/2.0.0/gems/sequenceserver-1.0.2/lib/sequenceserver/database.rb:109:in `new’

/Library/Ruby/Gems/2.0.0/gems/sequenceserver-1.0.2/lib/sequenceserver/database.rb:109:in `block (2 levels) in scan_databases_dir’

/Library/Ruby/Gems/2.0.0/gems/sequenceserver-1.0.2/lib/sequenceserver/database.rb:106:in `each_line’

/Library/Ruby/Gems/2.0.0/gems/sequenceserver-1.0.2/lib/sequenceserver/database.rb:106:in `block in scan_databases_dir’

/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/open3.rb:217:in `popen_run’

/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/open3.rb:99:in `popen3’

/Library/Ruby/Gems/2.0.0/gems/sequenceserver-1.0.2/lib/sequenceserver/database.rb:102:in `scan_databases_dir’

/Library/Ruby/Gems/2.0.0/gems/sequenceserver-1.0.2/lib/sequenceserver.rb:130:in `init_database’

/Library/Ruby/Gems/2.0.0/gems/sequenceserver-1.0.2/lib/sequenceserver.rb:40:in `init’

/Library/Ruby/Gems/2.0.0/gems/sequenceserver-1.0.2/bin/sequenceserver:131:in `block (2 levels) in <top (required)>’

/Library/Ruby/Gems/2.0.0/gems/slop-3.6.0/lib/slop.rb:260:in `call’

/Library/Ruby/Gems/2.0.0/gems/slop-3.6.0/lib/slop.rb:260:in `parse!’

/Library/Ruby/Gems/2.0.0/gems/slop-3.6.0/lib/slop.rb:65:in `parse!’

/Library/Ruby/Gems/2.0.0/gems/sequenceserver-1.0.2/bin/sequenceserver:12:in `<top (required)>’

/usr/bin/sequenceserver:23:in `load’

/usr/bin/sequenceserver:23:in `’

Hi, I’m having the same error, I tried to reformat my databases, rename them avoiding rare chars (I use only letters) and nothing works.
Any suggestion?

Hi Alessandro,

Thanks for showing us that more than one person is experiencing this problem. Can you please provide some more information? Specifically, what is the contents of the directory that you are scanning? Is there any files with non-standard characters?


Ah, my apologies I was a bit behind on reading the mailing list. I assume this error has been fixed as of 1.0.4.

Yup, this is now fixed.

– Priyam