blast method not found

My sequeceserver installation were working file till some time back but now they are having issues,

Whenever I start any search through sequence server or press the blue button on bottom, it redirects to another page with a url having “resut” in it and the page says “No Blast method selected”

Kindly help to resolve this issue.

Hi Parichit,

Would you be able to provide some more detail please? For instance, what version of seqserv are you using? Have you dsabled javascript in your browser? On the commandline where the server is running, what is the log when you press the blue button?


Hi Ben, thanks for taking interest,

I am using version 0.8.5 and jabascript are working just fine in my browser , as i already said I have used sequenceservers previously and it worked just fine, only this time when I click on “blastn” button after pasting fasta sequence , the next page says “No BLAST method provided”.

On the command line there is no abrupt message or warning that can help me to locate the issue so I am pretty helpless in that side but to post issue in this group.

For Note:
This issue has been observed only in chrome browsers not in firefox but still more confusing is the fact that in some chrome browsers sequenceserver is working fine but in other chrome browsers it is saying “No blast method found” after pressing “blastn” button.

Kindly advise how to deal with this issue.


Can you please copy and paste the log on the command line after you have pressed the blue button and it fails? Even if there is no abrupt error it can still help understand what is going on.

I’m also confused about when you say “the next page says “No BLAST method provided”.” Can you send a screenshot?


The log entries are as follows,

  • → /favicon.ico - - [25/Nov/2013 15:30:30] “POST / HTTP/1.1” 400 25 0.0092 - - [25/Nov/2013:15:30:30 IST] “POST / HTTP/1.1” 400 25 → /

Please note that I have changed the ip addresses in above logs due to system policies but this is the only thing that appears on command line after i press the button.

And, by next page I meant that browser is redirected to another page from sequenceserver default page when I press the “blastn” button but only thing that appears on next page is “No BLAST method provided” in top left corner in browser.

Thanks for asking me to clear the doubt otherwise it would have delayed things from your end.

Hi again,

I’m a bit stumped still, but I wonder, can you think of any differences between the chrome browsers that work and those that don’t?

Also, can I ask if there is a difference between the chromes when you go to the following URL?



Looks like
isn't preventing the default action of a button click, like it used

In file, <path to sequenceserver

/public/js/sequenceserver.js, please could you

1. At L215 add a parameter called 'event' to the function (which is
the submit event handler).
2. At L287 replace `return false` with `event.preventDefault()`

and see if that fixes the problem?


-- Priyam

Dear Priyam,

Kindly tell that where do I have to add the parameter, inside the function body ? or as an argument to function. Do I need to also initialize the parameter or just declare it.

Any help would be appreciated.


Dear Ben!


No I can not notice any drastic difference between chrome browsers that work and those that don’t.

I tried accessing the url sent by you but it opens up a page that says “No Input provided” in upper left corner of browser window.

Can you be little more specific about the url that you mentioned and exactly how do you want me to access it like by opening browser from server hosting sequenceserver or by any remote machine web browser.


As argument to the function:

$('#blast').submit(function (event) {

-- Priyam

Dear Priyam,

I tried making changes into sequenceserver.js as you suggested in your previous post but it did not resolve the issue.

Still the same problem occurs when I press “blastn” button.

Parichit, please could you test this pull request:

$ cd
$ git clone ss_fixed
$ cd ss_fixed
$ bin/sequenceserver

-- Priyam

Thanks Priyam for timely replying,

This time it worked , i cloned the fixed SS using git and used the new binary as you have explined in previous post,

No more “BLAST method not found error” , thanks .

By the way what could have caused the issue , I do not mean to intrude but am asking so that I can tell users here to not update their browsers or prevent any other browser plugin that could have resulted into that error on some chrome browsers.

Kindly also tell how can I replace my existing SS installations by the fixed one so that all hosted instances of SS use the fixed binary and no more BLAST method errors.

You rock! Thanks.

No seriously !!

You rock man.

Thanks for testing the pull request.

I made a new release (0.8.6) which includes the fix (courtesy
@hkmoon). `gem install sequenceserver` should patch your SS installations.

-- Priyam

Dear priyam,

Thanks for update.

I tried gem install sequenceserver but still on my hosted sequenceservers , I am still getting “BLAST method not found”

However if i manually launch sequenceserver form ss_fixed/bin then for this one it works but not for hosted sequenceservers that are integrated with apache2 using passenger.

I also installed new passenger and updated apache conf file to load new passenger but still the problem persists.

Kindly help!!!

Restarting Rack app hosted with Apache+Passenger:

Umm ... did you try hard refresh (Ctrl-F5 on Windows and Linux)?

-- Priyam

Dear priyam,

Thanks for update,

I tried refreshing and restarting the apache + passenger to no use. Still the same error in hosted SS instances, I in fact re installed sequenceserver-0.8.6 and again did the whole exercise but to no avail.

ruby version i ma using 1.9.2
passenger 4.0.6

Dear priyam,

Thanks for update,

I tried refreshing and restarting the apache + passenger to no use. Still the same error in hosted SS instances, I in fact re installed sequenceserver-0.8.6 and again did the whole exercise but to no avail.

ruby version i ma using 1.9.2
passenger 4.0.6

More people are reporting “No BLAST method found error” in my intranet now, Can you possibly help in resolving this issue.

If you need remote login to my machine, I can arrange that just let me know.

Hey!!! everyone

It appears I have not properly setup the config file so the files were pointing to older db locations just for one instance which got me more confused…

And about “No BLAST method found error” , it was zeroed down to lacking of linking between js files used by SS. I upgraded my SS to 0.8.6 but Since I am not expert in ruby on Rails, So I did’t updated old js files with new ones and passenger continued using older files…

Issues resolved now!!!

As of Now Olympus has not Fallen!!!

Thanks to Priyam @@@@@@ for helping.